FilterStringEndsWith Class


Filter String Ends With Class

Tests whether string values from the document end with a certain string.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringEndsWith : FilterStringRuleEvaluator

The FilterStringEndsWith type exposes the following members.

Constructors
Name Description
Public method FilterStringEndsWith Constructs an instance of FilterStringEndsWith.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterStringRuleEvaluator )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterStringRuleEvaluator )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Evaluate Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
(Inherited from FilterStringRuleEvaluator )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also