LineLoad Class


Line Load Class

An object that represents a force/moment applied in a linear manner.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineLoad : LoadBase

The LineLoad type exposes the following members.

Properties
Name Description
Public property EndPoint Returns the three dimensional location of the end point for the line load.
Public property ForceVector1 The force vector applied to the start point of the line load, oriented according to OrientTo setting.
Public property ForceVector2 The force vector applied to the end point of the line load, oriented according to OrientTo setting.
Public property IsProjected Indicates if the load is projected.
Public property IsUniform Indicates if the load is uniform.
Public property MomentVector1 The moment vector applied to the start point of the line load, oriented according to OrientTo setting.
Public property MomentVector2 The moment vector applied to the end point of the line load, oriented according to OrientTo setting.
Public property StartPoint Returns the three dimensional location of the start point for the line load.
Top
Methods
Name Description
Public method Static member Create(Document, ElementId, XYZ, XYZ, LineLoadType) Creates a new hosted line load within the project.
Public method Static member Create(Document, ElementId, Curve, XYZ, XYZ, LineLoadType) Creates a new custom line load within the project.
Public method Static member Create(Document, ElementId, Int32, XYZ, XYZ, LineLoadType) Creates a new hosted line load within the project.
Public method GetCurve Returns curve that define geometry of the line load.
Public method Static member IsCurveInsideHostBoundaries Indicates if the curve is inside panel's boundaries or on panel's edges or if the curve is on the member's curve.
Public method Static member IsValidHostId Indicates if the provided host id can host line loads The document containing both the host and the load The id of the analytical element that is about to host a line load True if a line load can be placed on the input host id
Public method SetCurve Sets the curve for the line load.
Public method SetPoints Sets start and end point of the line load.
Top
Remarks
The load/moment may be uniform or it may vary between the two ends of the line.
Example
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.ForceVector1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.ForceVector2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.MomentVector1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.MomentVector2));

     //Whether the load is projected or not
     if (lineLoad.IsProjected)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (false != lineLoad.IsUniform)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     TaskDialog.Show("Revit",information.ToString());
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
See Also