LineLoad Class


Line Load Class

An object that represents a force/moment applied in a linear manner.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineLoad : LoadBase

The LineLoad type exposes the following members.

Properties
Name Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property Code example BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property Code example CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property Code example DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property Code example DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property EndPoint Returns the three dimensional location of the end point for the line load.
Public property ForceVector1 The force vector applied to the start point of the line load, oriented according to OrientTo setting.
Public property ForceVector2 The force vector applied to the end point of the line load, oriented according to OrientTo setting.
Public property Code example Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property HostElementId The host element ID for the load.
(Inherited from LoadBase )
Public property Code example Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsConstrainedOnHost The load is constrained to host or not.
(Inherited from LoadBase )
Public property IsHosted Indicates if the Load is hosted or non-hosted.
(Inherited from LoadBase )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsProjected Indicates if the load is projected.
Public property IsReaction The load is reaction option.
(Inherited from LoadBase )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsUniform Indicates if the load is uniform.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property LoadCase The load case for the load.
(Inherited from LoadBase )
Public property LoadCaseId The load case ID for the load.
(Inherited from LoadBase )
Public property LoadCaseName The name of the load case to which this load belongs.
(Inherited from LoadBase )
Public property LoadCategoryName The name of the category to which this load belongs.
(Inherited from LoadBase )
Public property LoadNatureName A string representing the nature of the load.
(Inherited from LoadBase )
Public property Code example Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property MomentVector1 The moment vector applied to the start point of the line load, oriented according to OrientTo setting.
Public property MomentVector2 The moment vector applied to the end point of the line load, oriented according to OrientTo setting.
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property OrientTo The load orientation option.
(Inherited from LoadBase )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Code example Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Code example Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property StartPoint Returns the three dimensional location of the start point for the line load.
Public property Code example UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property WorkPlaneId Id of the work plane which may determine the orientation of the load.
(Inherited from LoadBase )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method Static member Create(Document, ElementId, XYZ, XYZ, LineLoadType) Creates a new hosted line load within the project.
Public method Static member Create(Document, ElementId, Curve, XYZ, XYZ, LineLoadType) Creates a new custom line load within the project.
Public method Static member Create(Document, ElementId, Int32, XYZ, XYZ, LineLoadType) Creates a new hosted line load within the project.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element )
Public method GetCurve Returns curve that define geometry of the line load.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method Code example GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method Static member IsCurveInsideHostBoundaries Indicates if the curve is inside panel's boundaries or on panel's edges or if the curve is on the member's curve.
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsOrientToPermitted Indicates if the provided orientation is permitted for this load.
(Inherited from LoadBase )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method Static member IsValidHostId Indicates if the provided host id can host line loads The document containing both the host and the load The id of the analytical element that is about to host a line load True if a line load can be placed on the input host id
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method RemoveHostConstraint Removes constraint from host for this load.
(Inherited from LoadBase )
Public method SetCurve Sets the curve for the line load.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method SetPoints Sets start and end point of the line load.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The load/moment may be uniform or it may vary between the two ends of the line.
Example
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.ForceVector1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.ForceVector2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.MomentVector1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.MomentVector2));

     //Whether the load is projected or not
     if (lineLoad.IsProjected)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (false != lineLoad.IsUniform)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     TaskDialog.Show("Revit",information.ToString());
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
See Also