Building |
Creates a new instance of a BuildingOperatingDaySchedule.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document to create the new BuildingOperatingDaySchedule element.
- name String
- The intended name of the newly created BuildingOperatingDaySchedule, may be modified to disambiguate with existing element.
Return Value
BuildingOperatingDayScheduleThe newly created BuildingOperatingDaySchedule.

Exception | Condition |
---|---|
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name must be trimmed. -or- name is an empty string or contains only whitespace. |
ArgumentNullException | A non-optional argument was null |

The new BuildingOperatingDaySchedule will have all values set to off.