PlaceInHost Method


Fabric Sheet Place In Host Method

Inserts the single Fabric Sheet instance into the host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PlaceInHost(
	Element hostElement,
	Transform transform
)

Parameters

hostElement Element
A structural element that will host the Fabric Sheet. The element must support fabric hosting.
transform Transform
The transform that defines the placement of the instance single Fabric Sheet.
Exceptions
Exception Condition
ArgumentException The host Element is not a valid host for Fabric Sheet. -or- transform defines the placement out of the host.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException transform is not conformal.
See Also