IExternalEventHandler Interface


IExternal Event Handler Interface

An interface to be executed when an external event is raised.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExternalEventHandler

The IExternalEventHandler type exposes the following members.

Methods
Name Description
Public method Execute This method is called to handle the external event.
Public method GetName String identification of the event handler.
Top
Remarks
An instance of a class implementing this interface will be registered with Revit first, and every time the corresponding external event is raised, the Execute method of this interface will be invoked.
See Also