SetCellType Method (Int32, Int32, CellType)


Table Section Data Set Cell Type(Int 32, Int 32, Cell Type) Method

Sets a cell's Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCellType(
	int nRow,
	int nCol,
	CellType type
)

Parameters

nRow Int32
nCol Int32
type CellType
Exceptions
Exception Condition
ArgumentException A CellType.CustomField can't be set. -or- The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This operation is forbidden for cells in standard schedule body sections.
See Also