Item Property


Export Lineweight Table Item Property

A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportLineweightInfo this[
	ExportLineweightKey lineweightKey
] { get; set; }

Parameters

lineweightKey ExportLineweightKey

Return Value

ExportLineweightInfo
A copy of the ExportLineweightInfo .
Exceptions
Exception Condition
ArgumentException When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.
See Also