PolyLine Class


Poly Line Class

A polyline.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PolyLine : GeometryObject

The PolyLine type exposes the following members.

Properties
Name Description
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property NumberOfCoordinates Gets the number of the coordinate points.
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method Clone Returns a copy of this polyline.
Public method Static member Create Creates a polyline with coordinate points provided.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method Evaluate Evaluates a parameter on the polyline.
Public method GetCoordinate Gets the coordinate point of the specified index.
Public method GetCoordinates Gets the coordinate points of the polyline.
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetOutline Gets the outline of the polyline.
Public method GetTransformed Gets the copy of the polyline which is applied the specified transformation.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A polyline in space is defined by a set of coordinate points.
See Also