GetIconPath Method


IExternal Resource Server Get Icon Path Method

Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
string GetIconPath()

Return Value

String
The image file of the server.
Remarks

The specified image will be displayed in the browser dialogs when the user is selecting a resource of a compatible type.

The return must be the full path to an icon file containing 48x48, 32x32 and 16x16 pixel images.

If this method returns anything other than a valid icon file, a default image will be used for the server.

See Also