Piping |
Gets the static pressure of this piping system.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
InvalidOperationException | The static pressure can not be calculated for this system. |

The system static pressure is calculated in the non-blocking evaluation framework. The caller may set up callbacks that react to the asynchronous calculation results. If no callback is set up (e.g, called from third-party applications), the calculation is automatically switched to synchronous calculation so the caller can access the up-to-date result. Similarly, the public method get_ParameterValue(BuiltInParameter.RBS_PIPE_STATIC_PRESSURE) has the same behavior. Due to this change, the parameter RBS_PIPE_STATIC_PRESSURE no longer supports dynamic model update.