GetRootId Method


Revit Link Type Get Root Id Method

Gets the id of the top-level link which this link is linked into.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetRootId()

Return Value

ElementId
The id of the top-level link which this link is ultimately linked under, or invalidElementId if this link is a top-level link.
Remarks
This function will always return the id of a top-level link, or invalidElementId. Given the link structure A -> B -> C, then calling this function on C will return A's id. Call GetParentId to get B's id.
See Also