FunctionId Class


Function Id Class

The information of a function throwing an exception.
Inheritance Hierarchy
System Object
Autodesk.Revit.Exceptions FunctionId

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class FunctionId : ISerializable

The FunctionId type exposes the following members.

Properties
Name Description
Public property File The name of the file including the function throwing an exception.
Public property Function The name of the function throwing an exception.
Public property Line The line number of the function throwing an exception.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetObjectData Retrieves data needed to serialize the target object.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also