FunctionId Class


Function Id Class

The information of a function throwing an exception.
Inheritance Hierarchy
System Object
Autodesk.Revit.Exceptions FunctionId

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class FunctionId : ISerializable

The FunctionId type exposes the following members.

Properties
Name Description
Public property File The name of the file including the function throwing an exception.
Public property Function The name of the function throwing an exception.
Public property Line The line number of the function throwing an exception.
Top
Methods
Name Description
Public method GetObjectData Retrieves data needed to serialize the target object.
Top
See Also