ModelPathUtils Class


Model Path Utils Class

Utility functions using ModelPaths
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ModelPathUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ModelPathUtils

The ModelPathUtils type exposes the following members.

Properties
Name Description
Public property Static member CloudRegionEMEA The name of cloud region EMEA.
Public property Static member CloudRegionUS The name of cloud region US.
Top
Methods
Name Description
Public method Static member ConvertCloudGUIDsToCloudPath Converts a pair of cloud project and model GUIDs to a valid cloud path.
Public method Static member ConvertModelPathToUserVisiblePath Gets a string version of the path of a given ModelPath.
Public method Static member ConvertUserVisiblePathToModelPath Converts a user-visible path (string) to a ModelPath.
Public method Static member IsValidUserVisibleFullServerPath Determines whether the given string represents a valid server path.
Top
See Also