Autodesk.Revit.DB.Visual Namespace


Autodesk. Revit. DB. Visual Namespace

Classes
Class Description
Public class AdvancedGlazing A static class that provides access to the property names that appear in the AdvancedGlazing visual asset schema.
Public class AdvancedLayered A static class that provides access to the property names that appear in the AdvancedLayered visual asset schema.
Public class AdvancedMetal A static class that provides access to the property names that appear in the AdvancedMetal visual asset schema.
Public class AdvancedOpaque A static class that provides access to the property names that appear in the AdvancedOpaque visual asset schema.
Public class AdvancedTransparent A static class that provides access to the property names that appear in the AdvancedTransparent visual asset schema.
Public class AdvancedWood A static class that provides access to the property names that appear in the AdvancedWood visual asset schema.
Public class Code example AppearanceAssetEditScope A scope object that provides special access and limitations related to editing appearance assets and their related elements.
Public class Code example Asset Represents a connected property of material.
Public class AssetProperties Represents a set of asset property(s).
Public class AssetProperty Represents a property of material.
Public class AssetPropertyBoolean Represents a property of material.
Public class AssetPropertyDistance Represents a property of material.
Public class AssetPropertyDouble Represents a property of material.
Public class AssetPropertyDoubleArray2d Represents a property consisting of an array of double values.
Public class AssetPropertyDoubleArray3d Represents a vector or point property.
Public class AssetPropertyDoubleArray4d Represents a color property of material.
Public class AssetPropertyDoubleMatrix44 Represents a property consisting of an array of double values.
Public class AssetPropertyEnum Represents a property of material.
Public class AssetPropertyFloat Represents a property of material.
Public class AssetPropertyFloatArray Represents a property consisting of an array of float values.
Public class AssetPropertyInt64 Represents a property of Int64 value.
Public class AssetPropertyInteger Represents a property of material.
Public class AssetPropertyList Represents a list of AssetProperty(s).
Public class AssetPropertyReference Represents a connected property of material.
Public class AssetPropertyString Represents a property of material.
Public class AssetPropertyTime Represents a connected property of material.
Public class AssetPropertyUInt64 Represents a property of UInt64 value.
Public class AssetSet
Public class AssetSetIterator
Public class BumpMap A static class that provides access to the property names that appear in the BumpMap visual asset schema.
Public class Ceramic A static class that provides access to the property names that appear in the Ceramic visual asset schema.
Public class Checker A static class that provides access to the property names that appear in the Checker visual asset schema.
Public class Concrete A static class that provides access to the property names that appear in the Concrete visual asset schema.
Public class Generic A static class that provides access to the property names that appear in the Generic visual asset schema.
Public class Glazing A static class that provides access to the property names that appear in the Glazing visual asset schema.
Public class Gradient A static class that provides access to the property names that appear in the Gradient visual asset schema.
Public class Hardwood A static class that provides access to the property names that appear in the Hardwood visual asset schema.
Public class Marble A static class that provides access to the property names that appear in the Marble visual asset schema.
Public class MasonryCMU A static class that provides access to the property names that appear in the MasonryCMU visual asset schema.
Public class Metal A static class that provides access to the property names that appear in the Metal visual asset schema.
Public class MetallicPaint A static class that provides access to the property names that appear in the MetallicPaint visual asset schema.
Public class Mirror A static class that provides access to the property names that appear in the Mirror visual asset schema.
Public class Noise A static class that provides access to the property names that appear in the Noise visual asset schema.
Public class PlasticVinyl A static class that provides access to the property names that appear in the PlasticVinyl visual asset schema.
Public class SchemaCommon A static class that provides access to the property names that appear in all the visual Asset types.
Public class SolidGlass A static class that provides access to the property names that appear in the SolidGlass visual asset schema.
Public class Speckle A static class that provides access to the property names that appear in the Speckle visual asset schema.
Public class Stone A static class that provides access to the property names that appear in the Stone visual asset schema.
Public class Tile A static class that provides access to the property names that appear in the Tile visual asset schema.
Public class UnifiedBitmap A static class that provides access to the property names that appear in the UnifiedBitmap visual asset schema.
Public class WallPaint A static class that provides access to the property names that appear in the WallPaint visual asset schema.
Public class Water A static class that provides access to the property names that appear in the Water visual asset schema.
Public class Wave A static class that provides access to the property names that appear in the Wave visual asset schema.
Public class Wood A static class that provides access to the property names that appear in the Wood visual asset schema.
Enumerations
Enumeration Description
Public enumeration AssetPropertyType Enumerated type listing the type of asset property
Public enumeration AssetType Enumerated asset types
Public enumeration BumpmapType The enumerated type representing the permitted values for the asset property "BumpmapType" from the "BumpMap" schema.
Public enumeration CeramicApplicationType The enumerated type representing the permitted values for the asset property "CeramicApplication" from the "Ceramic" schema.
Public enumeration CeramicBumpType The enumerated type representing the permitted values for the asset property "CeramicBump" from the "Ceramic" schema.
Public enumeration CeramicPatternType The enumerated type representing the permitted values for the asset property "CeramicPattern" from the "Ceramic" schema.
Public enumeration CeramicType The enumerated type representing the permitted values for the asset property "CeramicType" from the "Ceramic" schema.
Public enumeration CommonSharedAssetType The enumerated type representing the permitted values for the asset property "CommonSharedAsset" from the "Ceramic" schema.
Public enumeration ConcreteBrightmodeType The enumerated type representing the permitted values for the asset property "ConcreteBrightmode" from the "Concrete" schema.
Public enumeration ConcreteFinishType The enumerated type representing the permitted values for the asset property "ConcreteFinish" from the "Concrete" schema.
Public enumeration ConcreteSealantType The enumerated type representing the permitted values for the asset property "ConcreteSealant" from the "Concrete" schema.
Public enumeration GlazingTransmittanceColorType The enumerated type representing the permitted values for the asset property "GlazingTransmittanceColor" from the "Glazing" schema.
Public enumeration GradientInterpolationType The enumerated type representing the permitted values for the asset property "GradientInterpolation" from the "Gradient" schema.
Public enumeration GradientNoiseType The enumerated type representing the permitted values for the asset property "GradientNoise" from the "Gradient" schema.
Public enumeration GradientType The enumerated type representing the permitted values for the asset property "GradientType" from the "Gradient" schema.
Public enumeration HardwoodApplicationType The enumerated type representing the permitted values for the asset property "HardwoodApplication" from the "Hardwood" schema.
Public enumeration HardwoodFinishType The enumerated type representing the permitted values for the asset property "HardwoodFinish" from the "Hardwood" schema.
Public enumeration HardwoodImperfectionsType The enumerated type representing the permitted values for the asset property "HardwoodImperfections" from the "Hardwood" schema.
Public enumeration HardwoodTintEnabledType The enumerated type representing the permitted values for the asset property "HardwoodTintEnabled" from the "Hardwood" schema.
Public enumeration LayeredNdfType The enumerated type representing the permitted values for the asset property "LayeredNdfType" from the "AdvancedLayered" schema.
Public enumeration MasonryCMUApplicationType The enumerated type representing the permitted values for the asset property "MasonryCMUApplication" from the "MasonryCMU" schema.
Public enumeration MasonryCMUPatternType The enumerated type representing the permitted values for the asset property "MasonryCMUPattern" from the "MasonryCMU" schema.
Public enumeration MasonryCMUType The enumerated type representing the permitted values for the asset property "MasonryCMUType" from the "MasonryCMU" schema.
Public enumeration MetalFinishType The enumerated type representing the permitted values for the asset property "MetalFinish" from the "Metal" schema.
Public enumeration MetallicpaintFinishType The enumerated type representing the permitted values for the asset property "MetallicpaintFinish" from the "MetallicPaint" schema.
Public enumeration MetallicpaintFlecksType The enumerated type representing the permitted values for the asset property "MetallicpaintFlecks" from the "MetallicPaint" schema.
Public enumeration MetallicpaintPearlType The enumerated type representing the permitted values for the asset property "MetallicpaintPearl" from the "MetallicPaint" schema.
Public enumeration MetallicpaintTopcoatType The enumerated type representing the permitted values for the asset property "MetallicpaintTopcoat" from the "MetallicPaint" schema.
Public enumeration MetalPatternType The enumerated type representing the permitted values for the asset property "MetalPattern" from the "Metal" schema.
Public enumeration MetalPerforationsType The enumerated type representing the permitted values for the asset property "MetalPerforations" from the "Metal" schema.
Public enumeration MetalType The enumerated type representing the permitted values for the asset property "MetalType" from the "Metal" schema.
Public enumeration NoiseType The enumerated type representing the permitted values for the asset property "NoiseType" from the "Noise" schema.
Public enumeration PlasticvinylApplicationType The enumerated type representing the permitted values for the asset property "PlasticvinylApplication" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylBumpType The enumerated type representing the permitted values for the asset property "PlasticvinylBump" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylPatternType The enumerated type representing the permitted values for the asset property "PlasticvinylPattern" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylType The enumerated type representing the permitted values for the asset property "PlasticvinylType" from the "PlasticVinyl" schema.
Public enumeration SolidglassBumpEnableType The enumerated type representing the permitted values for the asset property "SolidglassBumpEnable" from the "SolidGlass" schema.
Public enumeration SolidglassTransmittanceType The enumerated type representing the permitted values for the asset property "SolidglassTransmittance" from the "SolidGlass" schema.
Public enumeration StoneApplicationType The enumerated type representing the permitted values for the asset property "StoneApplication" from the "Stone" schema.
Public enumeration StoneBumpType The enumerated type representing the permitted values for the asset property "StoneBump" from the "Stone" schema.
Public enumeration StonePatternType The enumerated type representing the permitted values for the asset property "StonePattern" from the "Stone" schema.
Public enumeration SurfaceNdfType The enumerated type representing the permitted values for the asset property "SurfaceNdfType" from the "AdvancedLayered" schema.
Public enumeration TileBrickType The enumerated type representing the permitted values for the asset property "TileBrickType" from the "Tile" schema.
Public enumeration WallpaintApplicationType The enumerated type representing the permitted values for the asset property "WallpaintApplication" from the "WallPaint" schema.
Public enumeration WallpaintFinishType The enumerated type representing the permitted values for the asset property "WallpaintFinish" from the "WallPaint" schema.
Public enumeration WaterTintEnableType The enumerated type representing the permitted values for the asset property "WaterTintEnable" from the "Water" schema.
Public enumeration WaterType The enumerated type representing the permitted values for the asset property "WaterType" from the "Water" schema.
Public enumeration WaveDistributionType The enumerated type representing the permitted values for the asset property "WaveDistribution" from the "Wave" schema.
Public enumeration WoodPoreType The enumerated type representing the permitted values for the asset property "WoodPoreType" from the "AdvancedLayered" schema.