ReleaseConditions Class


Release Conditions Class

An object that represents a Release Conditions on analytical element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure ReleaseConditions

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReleaseConditions : IDisposable

The ReleaseConditions type exposes the following members.

Constructors
Name Description
Public method ReleaseConditions(Boolean) Creates a new instance of ReleaseConditions.
Public method ReleaseConditions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) Creates a new instance of ReleaseConditions.
Top
Properties
Name Description
Public property Fx Gets or Sets the Fx of the release type.
Public property Fy Gets or Sets the Fy of the release type.
Public property Fz Gets or Sets the Fz of the release type.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Mx Gets or Sets the Mx of the release type.
Public property My Gets or Sets the My of the release type.
Public property Mz Gets or Sets the Mz of the release type.
Public property Start Gets or Sets the position of release type. True for start, false for end.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ReleaseConditions
Top
See Also