Importer |
Updates the category of a DirectShape.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static void UpdateDirectShapeCategory(
DirectShape directShape,
ElementId newCategoryId
)
Parameters
- directShape DirectShape
- The DirectShape.
- newCategoryId ElementId
- The new category id.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Use this function carefully, as it could result in a mismatch between DirectShape and DirectShapeType categories.