Assembly |
Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static View3D Create3DOrthographic(
Document document,
ElementId assemblyInstanceId,
ElementId viewTemplateId,
bool isAssigned
)
Parameters
- document Document
- The document to which the view will be added.
- assemblyInstanceId ElementId
- Id of the assembly instance that owns the new view.
- viewTemplateId ElementId
- Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
- isAssigned Boolean
- If true, the template will be assigned, if false, the template will be applied.
Return Value
View3DA new orthographic 3D assembly view.

Exception | Condition |
---|---|
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the geom view. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |