Direct |
Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsValidShape(
IList<GeometryObject> shape,
DirectShapeTargetViewType viewType
)
Parameters
- shape IList GeometryObject
- Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType DirectShapeTargetViewType
- The view type this shape is intended for.
Return Value
BooleanTrue if the supplied shape passes the validation criteria.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |