GetAllMaterials Method


Fabrication Configuration Get All Materials Method

Gets all material identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<int> GetAllMaterials(
	FabricationPart part
)

Parameters

part FabricationPart
The fabrication part.

Return Value

IList Int32
An array of material identifiers.
Remarks
If a part is passed, only returns materials which are valid for the part, otherwise returns all materials.
See Also