ViewShapeBuilder Class


View Shape Builder Class

Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB ViewShapeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewShapeBuilder : ShapeBuilder

The ViewShapeBuilder type exposes the following members.

Constructors
Name Description
Public method ViewShapeBuilder Default constructor for an ViewShapeBuilder object.
Public method ViewShapeBuilder(DirectShapeTargetViewType) A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Top
Properties
Name Description
Public property ViewNormal Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.
Public property ViewType View type where the view-specific shape currently being built will be used
Top
Methods
Name Description
Public method AddCurve Add a curve to the GRep associated to this ViewShapeBuilder.
Public method Reset Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.
Public method ValidateCurve(Curve) Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
Public method Static member ValidateCurve(Curve, DirectShapeTargetViewType) Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
Public method Static member ValidateShape Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
Public method Static member ValidateViewType Validates the incoming view type. As of today, the only allowed view type is Plan.
Top
Remarks
The validation functionality is used by DirectShape to validate the incoming shape.
See Also