MakeBound Method


Curve Make Bound Method

Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void MakeBound(
	double startParameter,
	double endParameter
)

Parameters

startParameter Double
The new parameter of the start point.
endParameter Double
The new parameter of the end point.
Exceptions
Exception Condition
ArgumentException Thrown when the specified values are infinite.
InvalidOperationException Thrown when endParameter is smaller than startParameter.
Remarks
If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.
See Also