ExternalServiceRegistry Class


External Service Registry Class

This class gives access to external services. Use it to register external services with Revit and execute them. Only the application that registers a service is allowed to execute it.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalServiceRegistry

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternalServiceRegistry

The ExternalServiceRegistry type exposes the following members.

Methods
Name Description
Public method Static member ExecuteService(Guid, IExternalData) Execute a service independently of any document.
Public method Static member ExecuteService(Guid, Document, IExternalData) Execute the service for the given document.
Public method Static member ExecuteService(Guid, Guid, IExternalData) Execute the service by the given server.
Public method Static member GetService Returns an instance of an object that represents the external service with the given Id.
Public method Static member GetServices Returns a collection of all external services currently registered in Revit.
Public method Static member RegisterService(ISingleServerService, ExternalServiceOptions) A method to register a single-server service.
Public method Static member RegisterService(IMultiServerService, ExternalServiceOptions, ExecutionPolicy) A method to register a multi-server service.
Public method Static member RegisterService(ISingleServerService, Guid, ExternalServiceOptions) A method to register a mandatory, single-server service.
Top
See Also