AXMImportOptions Class


AXMImport Options Class

The import options used to import AXM format files.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AXMImportOptions : BaseImportOptions

The AXMImportOptions type exposes the following members.

Constructors
Name Description
Public method AXMImportOptions Constructs a new instance of AXMImportOptions with default values of all properties.
Public method AXMImportOptions(AXMImportOptions) Constructs a new instance of AXMImportOptions as a copy of the provided import options.
Top
Properties
Name Description
Public property AutoCorrectAlmostVHLines Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
(Inherited from BaseImportOptions )
Public property ColorMode Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
(Inherited from BaseImportOptions )
Public property CustomScale Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
(Inherited from BaseImportOptions )
Public property ImportLevels Indicate if levels are to be imported. False by default.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BaseImportOptions )
Public property OrientToView Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
(Inherited from BaseImportOptions )
Public property Placement Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
(Inherited from BaseImportOptions )
Public property ReferencePoint The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
(Inherited from BaseImportOptions )
Public property ThisViewOnly Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
(Inherited from BaseImportOptions )
Public property Unit The unit of measure for imported geometry.
(Inherited from BaseImportOptions )
Public property VisibleLayersOnly Only import the visible layers.
(Inherited from BaseImportOptions )
Top
Methods
Name Description
Public method Dispose
(Inherited from BaseImportOptions )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetDefaultLengthUnit Get the default length unit used for importing unitless files.
(Inherited from BaseImportOptions )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLayerSelection Get all set layers name which user want to import into Revit.
(Inherited from BaseImportOptions )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetDefaultLengthUnit Set the default length unit used for importing unitless files.
(Inherited from BaseImportOptions )
Public method SetLayerSelection Set the layers name which user want to import into Revit.
(Inherited from BaseImportOptions )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also