CategoryNameMapIterator Class


Category Name Map Iterator Class

An iterator to a category name map.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB CategoryNameMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class CategoryNameMapIterator : APIObject, 
	IEnumerator

The CategoryNameMapIterator type exposes the following members.

Constructors
Name Description
Public method CategoryNameMapIterator For Internal Use Only.
Top
Properties
Name Description
Public property Current Retrieves the category that is the current focus of the iterator.
Public property Key Retrieves the category name that is the current focus of the iterator.
Top
Methods
Name Description
Public method MoveNext Move the iterator one item forward.
Public method Reset Bring the iterator back to the start of the map.
Top
See Also