Independent |
Checks if the IndependentTag has a tag behavior.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


When the IndependentTag object does not have a tag behavior, functions related to references, leaders and orientation will throw an exception. In this case, the element may be used for geometry augmentation. [!:Autodesk::Revit::Proxy::DB::IGeometryAugmentationServer] The list of functions that would fail if not in tag mode: [M:Autodesk.Revit.DB.IndependentTag.AddReferences(System.Collections.Generic.IList`1{Autodesk.Revit.DB.Reference})] GetLeaderElbow(Reference) GetLeaderEnd(Reference) HasLeader HasLeaderElbow(Reference) IsLeaderVisible(Reference) LeaderEndCondition LeadersPresentationMode MergeElbows [M:Autodesk.Revit.DB.IndependentTag.RemoveReferences(System.Collections.Generic.IList`1{Autodesk.Revit.DB.Reference})] SetIsLeaderVisible(Reference, Boolean) SetLeaderEnd(Reference, XYZ) SetLeaderElbow(Reference, XYZ) TagOrientation TagText