Create Method (Document, Reference)


Sketch Plane Create(Document, Reference) Method

Creates a new sketch plane from a reference to a planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static SketchPlane Create(
	Document document,
	Reference planarFaceReference
)

Parameters

document Document
The document.
planarFaceReference Reference
The reference of the planar face where the sketch plane will be created.

Return Value

SketchPlane
The newly created sketch plane.
Exceptions
Exception Condition
ArgumentException Sketch plane creation is not allowed in this family. -or- The reference is not a planar face.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
A reference relationship will be created between the face and the sketch plane.
See Also