Structural |
Defines common set of parameters for structural section rectangular contour.

System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
More
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
More
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The StructuralSectionRectangular type exposes the following members.

Name | Description | |
---|---|---|
![]() | CentroidHorizontal | Distance from centroid to the left extremites along horizontal axis. |
![]() | CentroidVertical | Distance from centroid to the upper extremites along vertical axis. |
![]() | Height | Section height, depth. |
![]() | NameKey | Name Key |
![]() | Width | Section width. |

Name | Description | |
---|---|---|


System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionColdFormed
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteCross
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteRectangle
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteRectangleCut
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralF
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralH
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionIWelded
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionUserDefined
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionColdFormed
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteCross
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteRectangle
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteRectangleCut
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionConcreteT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralF
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralH
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionIWelded
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionUserDefined