GetRebarHostDirectNeighbors Method


Rebar Host Data Get Rebar Host Direct Neighbors Method

Returns a set of ElementIds for Elements joined to the provided host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetRebarHostDirectNeighbors(
	Element hostElement
)

Parameters

hostElement Element
The host element. Must be an element that can host reinforcement.

Return Value

ISet ElementId
The neighbor ids.
Exceptions
Exception Condition
ArgumentException hostElement is not a valid rebar host.
ArgumentNullException A non-optional argument was null
Remarks
This function returns the first level of neighbors for the provided host, meaning elements that are joined directly to the provided host element (not the neighbors of the joined elements also). These elements can also host reinforcement.
See Also