ReferenceWithContext Class


Reference With Context Class

An object including a reference to a geometric object and related context, as instance transform etc.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReferenceWithContext : IDisposable

The ReferenceWithContext type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Proximity The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ReferenceWithContext
Public method GetInstanceTransform Gets the transform of the instance.
Public method GetReference Gets the reference of the geometric object.
Top
Remarks
The ReferenceWithContext is used as the returned value from the method [!:Autodesk::Revit::DB::Document::FindReferencesWithContextByDirection] , ReferenceIntersector.Find(XYZ, XYZ), or ReferenceIntersector.FindNearest(XYZ, XYZ). It includes a reference intersecting a line extended in a certain direction from an origin point and the context of the geometric object, as the transform and proximity.
See Also