Analysis |
Contains colored surface settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisDisplayColoredSurfaceSettings | Constructs a default instance of colored surface settings. |
![]() | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object. |

Name | Description | |
---|---|---|
![]() | GridColor | Color of grid lines. |
![]() | GridLineWeight | Line weight of grid lines. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ShowContourLines | If true, show contour lines in the analysis display. |
![]() | ShowGridLines | If true, show grid lines in the analysis display. |
![]() | Transparency | Transparency percentage of colored surface |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEqual | Compares two colored surface settings objects. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |