SetBoldStatus Method (TextRange, Boolean)


Formatted Text Set Bold Status(Text Range, Boolean) Method

Sets the characters in a given text range to be bold or not bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetBoldStatus(
	TextRange textRange,
	bool isBold
)

Parameters

textRange TextRange
The given text range.
isBold Boolean
The desired bold status of characters in the given text range. True to set bold, false to set not bold.
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks

To make the numbers or letters in a list bold, apply the bold status to the carriage return character that ends the list paragraph.

The given text range should not be empty.

See Also