BuiltInFailures.LevelFailures Class


Built In Failures Level Failures Class

Failures about Level.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures LevelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class LevelFailures

The BuiltInFailures LevelFailures type exposes the following members.

Properties
Name Description
Public property Static member NoLevelsLeft There are no levels or plan views remaining in the project.
Public property Static member NoLevelsLeftReloading As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
Public property Static member StoryAboveDeleted The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
Public property Static member StoryAboveMoved The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
Public property Static member StoryAboveNonStoryLevel The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.
Top
See Also