PolymeshTopology Class


Polymesh Topology Class

A class representing topology of a polymesh.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PolymeshTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PolymeshTopology : IDisposable

The PolymeshTopology type exposes the following members.

Properties
Name Description
Public property DistributionOfNormals Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NumberOfFacets The number of facet in the polymesh.
Public property NumberOfNormals The number of normals associated with the polymesh
Public property NumberOfPoints The number of points in the polymesh
Public property NumberOfUVs The number of UV coordinates available for the polymesh.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PolymeshTopology
Public method GetFacet Returns a definition of one facet
Public method GetFacets Returns a definitions of all facets of the polymesh
Public method GetNormal Returns a normal vector at the given index
Public method GetNormals Returns all normals assigned to the polymesh
Public method GetPoint Returns one point at the given index.
Public method GetPoints Returns all points of the polymesh.
Public method GetUV Returns one UV coordinate at the given index.
Public method GetUVs Returns all UV coordinates assigned to the polymesh
Top
Remarks
Topology of a polymesh consists of a number of points and triangular facets formed by the points. Each facet is determined by three indices to the array of points. A polymesh may have UV coordinates assigned, and always has at least one normal associated. There may be more than one normal available for a non-planar polymesh; there may be as many normals as there are either facets or points in the polymesh. The DistributionOfNormals property indicates how normals are distributed along the polymesh.
See Also