Service |
This enumeration is used for specifying the most predominant service for the building or space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Member name | Value | Description |
---|---|---|
kCentralHeatingRadiators | 0 | Service Type is CentralHeatingRadiators. |
kCentralHeatingConvectors | 1 | Service Type is CentralHeatingConvectors. |
kCentralHeatingRadiantFloor | 2 | Service Type is CentralHeatingRadiantFloor. |
kCentralHeatingHotAir | 3 | Service Type is CentralHeatingHotAir. |
kOtherRoomHeater | 4 | Service Type is OtherRoomHeater. |
kRadiantHeaterFlue | 5 | Service Type is RadiantHeaterFlue. |
kRadiantHeaterNoFlue | 6 | Service Type is RadiantHeaterNoFlue. |
kRadiantHeaterMultiburner | 7 | Service Type is RadiantHeaterMultiburner. |
kForcedConvectionHeaterFlue | 8 | Service Type is ForcedConvectionHeaterFlue. |
kForcedConvectionHeaterNoFlue | 9 | Service Type is ForcedConvectionHeaterNoFlue. |
kNoServiceType | -1 | Service Type is NoServiceType. |
kVAVSingleDuct | 10 | Service Type is VAVSingleDuct. |
kVAVDualDuct | 11 | Service Type is VAVDualDuct. |
kVAVIndoorPackagedCabinet | 12 | Service Type is VAVIndoorPackagedCabinet. |
kVAVTerminalReheat | 13 | Service Type is VAVTerminalReheat. |
kFanCoilSystem | 14 | Service Type is FanCoilSystem. |
kInductionSystem | 15 | Service Type is InductionSystem. |
kConstantVolumeFixedOA | 16 | Service Type is ConstantVolumeFixedOA. |
kConstantVolumeVariableOA | 17 | Service Type is ConstantVolumeVariableOA. |
kConstantVolumeTerminalReheat | 18 | Service Type is ConstantVolumeTerminalReheat. |
kMultizoneHotDeckColdDeck | 19 | Service Type is MultizoneHotDeckColdDeck. |
kConstantVolumeDualDuct | 20 | Service Type is ConstantVolumeDualDuct. |
kRadiantCooledCeilings | 21 | Service Type is RadiantCooledCeilings. |
kActiveChilledBeams | 22 | Service Type is ActiveChilledBeams. |
kWaterLoopHeatPump | 23 | Service Type is WaterLoopHeatPump. |
kVariableRefrigerantFlow | 24 | Service Type is VariableRefrigerantFlow. |
kSplitSystemsWithNaturalVentilation | 25 | Service Type is SplitSystemsWithNaturalVentilation. |
kSplitSystemsWithMechanicalVentilation | 26 | Service Type is SplitSystemsWithMechanicalVentilation. |
kSplitSystemsWithMechanicalVentilationWithCooling | 27 | Service Type is SplitSystemsWithMechanicalVentilationWithCooling. |

This enumerated list corresponds to the serviceType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.