DefinitionGroups Class


Definition Groups Class

A specialized set of definition groups that allows creation of new groups.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DefinitionGroups

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DefinitionGroups : IEnumerable<DefinitionGroup>, 
	IDisposable

The DefinitionGroups type exposes the following members.

Properties
Name Description
Public property IsEmpty Identifies if the definition groups collection is empty.
Public property Item Retrieve a definition group by name.
Public property Size The number of definition groups in the collection.
Top
Methods
Name Description
Public method Contains Tests for the existence of a definition group within the collection.
Public method Create Create a new parameter definition group using the name provided.
Public method Dispose Releases all resources used by the DefinitionGroups
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Retrieves an enumerator to the collection.
Top
See Also