Transaction |
Starts the transaction group
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
TransactionStatusIf started successfully, this method returns TransactionStatus.Started.

Exception | Condition |
---|---|
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started. |

A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group. When groups are nested inside each other it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.