GetClosestStation Method


Alignment Get Closest Station Method

Calculates the alignment station closest to the given model point.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetClosestStation(
	XYZ point
)

Parameters

point XYZ
The model point for which to calculate the closest station.

Return Value

Double
The alignment station closest to the given model point, in Revit internal model units (standard Imperial feet).
See Also