GetElementFilterFromRule Method (PerformanceAdviserRuleId, Document)


Performance Adviser Get Element Filter From Rule(Performance Adviser Rule Id, Document) Method

Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementFilter GetElementFilterFromRule(
	PerformanceAdviserRuleId id,
	Document document
)

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.
document Document
Document for which performance problems are being checked.

Return Value

ElementFilter
The filter to restrict elements to be checked.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also