ExcavateBy Method


Toposolid Excavate By Method

Excavates the Toposolid by a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void ExcavateBy(
	ElementId elementId
)

Parameters

elementId ElementId
Id of the element used to excavate the Toposolid.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The element is not supported for Toposolid excavation operations.
See Also