IsValidUnit Method


Unit Utils Is Valid Unit Method

Checks whether a unit is valid for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidUnit(
	ForgeTypeId specTypeId,
	ForgeTypeId unitTypeId
)

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.
unitTypeId ForgeTypeId
Identifier of the unit to check.

Return Value

Boolean
True if the unit is valid, false otherwise.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also