GetAssociateFamilyParameterId Method


MEPFamily Connector Info Get Associate Family Parameter Id Method

Gets the associate family parameter id of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetAssociateFamilyParameterId(
	ElementId connectorParameterId
)

Parameters

connectorParameterId ElementId
connectorParameterId is defined in the family connector element.

Return Value

ElementId
Returns valid ElementId if the connectorParameterId associates to one family parameter; otherwise returns invalid ElementId.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also