AreGlobalParametersAllowed Method


Global Parameters Manager Are Global Parameters Allowed Method

Tests whether global parameters are allowed in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool AreGlobalParametersAllowed(
	Document document
)

Parameters

document Document
A revit document of interest.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
First of all, global parameters can be had in main project documents only; they are not supported in family documents. However, there may also be other circumstances due to which global parameters may be disallowed in a particular project, either temporarily or permanently.
See Also