Fabrication |
Rotates a connected fabrication part around the axis of the specified connector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void RotateConnectedPartByConnector(
Document document,
Connector connector,
double axisRotationBy
)
Parameters

Exception | Condition |
---|---|
ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- Connector is not connected. -or- Connector belongs to a fabrication part tap. -or- Fabrication part cannot be rotated because it is either unable to be re-sized or it is too constrained. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | rotate failed because the fabrication part geometry could not be modified accordingly. |

Attempts to resize rectangular and oval ends if the angle is a multiple of PI/2. Taps cannot be rotated. For rectangular and oval profiles only 90, 180 and 270 degree rotations are valid.