SetAllCapsStatus Method (TextRange, Boolean)


Formatted Text Set All Caps Status(Text Range, Boolean) Method

Sets the characters in a given text range to be in all caps or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAllCapsStatus(
	TextRange textRange,
	bool isAllCaps
)

Parameters

textRange TextRange
The given text range.
isAllCaps Boolean
The desired all caps status of characters in the given text range. True will render all characters in all caps. False will revert the characters back to their original mixed case.
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks

Removing the all caps status will revert the characters back to their original case. It will not make them lower case.

The given text range should not be empty.

See Also