AreSolidsEqual Method


Exporter IFCUtils Are Solids Equal Method

Determines whether two solids are identical, potentially offset from each other.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreSolidsEqual(
	Solid first,
	Solid second,
	out Transform trf
)

Parameters

first Solid
The first solid.
second Solid
The second solid
trf Transform
The offset transform

Return Value

Boolean
True if they are identical, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also