Item Property


Duct Size Settings Item Property

Get the DuctSizes for this DuctShape.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DuctSizes this[
	DuctShape ductShape
] { get; }

Parameters

ductShape DuctShape
The duct shape.

Return Value

DuctSizes
The DuctSizes for this DuctShape.
Exceptions
Exception Condition
ArgumentException There is no DuctSizes for this DuctShape.
ArgumentNullException A non-optional argument was NULL
See Also