MEPSupport |
Create family based stiffener on the specified fabrication ductwork.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FamilyInstance CreateDuctworkStiffener(
Document document,
ElementId familySymbolId,
ElementId hostId,
double distanceFromHostEnd
)
Parameters
- document Document
- The document.
- familySymbolId ElementId
- The id of a stiffener FamilySymbol.
- hostId ElementId
- The id of the host ductwork.
- distanceFromHostEnd Double
- The distance from the host primary end to place the hosted instance. Units are in feet (ft).
Return Value
FamilyInstanceThe new stiffener family instance.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- familySymbolId is not a valid Element identifier. -or- hostId is not a valid Element identifier. -or- Invalid familySymbolId for stiffeners. -or- Host is not a straight ductwork. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The distance from host primary end is out of range. |
InvalidOperationException | The profiles of family symbol and host are mismatch. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
RegenerationFailedException | Failed to create stiffener due to document regenerate error. |