RemoveAssociation Method


Analytical To Physical Association Manager Remove Association Method

This method will remove the association for the element with the given ElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveAssociation(
	ElementId id
)

Parameters

id ElementId
Id of the element for which we want to remove the association.
Exceptions
Exception Condition
ArgumentException This element doesn't have an association defined.
ArgumentNullException A non-optional argument was null
Remarks
If the id does not have any association, an exception is thrown.
See Also