Tabbed |
Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The TabbedDialogExtension type exposes the following members.

Name | Description | |
---|---|---|
![]() | TabbedDialogExtension | Constructs a extension instance with a control and ok action handler. |

Name | Description | |
---|---|---|
![]() | Control | The control. |
![]() | OnCancelAction | The cancel handler. |
![]() | OnOKAction | The ok handler. |
![]() | OnRestoreDefaultsAction | The restore defaults handler. |

Name | Description | |
---|---|---|
![]() | GetContextualHelp | Gets the contextual help. |
![]() | SetContextualHelp | Sets the contextual help. |

Each page has an associated user interface control and the handlers of buttons Cancel, Restore Defaults and help can optionally be set. The size of the control is limited to 305 (height) x 288 (width) in physical pixels.