Can |
The event arguments used by AddInCommandBinding's CanExecute event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The CanExecuteEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | CanExecute | The value that indicates whether the Command associated with this event can be executed. |
![]() | IsChecked | The value that indicates whether the UI associated with the Command associated with this event is in a checked state. |

Name | Description | |
---|---|---|
![]() | GetSelectedCategoryIds | Gets the category ids of selected elements. |