Can |
The event arguments used by AddInCommandBinding's CanExecute event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The CanExecuteEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | ActiveDocument | The active document. (Inherited from CommandEventArgs ) |
![]() | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs ) |
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs ) |
![]() | CanExecute | The value that indicates whether the Command associated with this event can be executed. |
![]() | CommandId | The command id. (Inherited from CommandEventArgs ) |
![]() | IsChecked | The value that indicates whether the UI associated with the Command associated with this event is in a checked state. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetSelectedCategoryIds | Gets the category ids of selected elements. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |